Rechercher dans Kiteb.net

Aujourd'hui: Le 22 octobre 2018
Visites aujourd'hui : 247
Top visites par jour : 28712
Le 21 mai 2018
Visiteurs en ligne: 2
  Accueil
Algo & programmation
edu
Matière informatique
Informatique
Formations
Exercices livre scolaire

Bac scientifiques

Exercices du livre scolaire (corrigés)



la structure conditionnelle


Exercice 5  : page 83

Saisir une chaîne de caractère et vérifier si elle est composée de plusieurs mots.

Corrigé :

Algorithme :

  1. Début mots

  2. Ecrire("Saisir une chaine de caractère :"), lire(ch)

  3. message <-- "Plusieurs mots"

  4. si pos(" ",ch)=0 alors Message <-- '' un seul mot''

Finsi

  1. Ecrire(Message) 

  2. Fin mots


Exercice 1  : page 102

Écrire un programme intitulé TOUCHE, qui affiche selon le cas, la nature du caractère( consonne, voyelle, chiffre ou symbole) correspondant à une touche saisie.

Corrigé :

Program touche ;

uses wincrt ;

var

nature : string ;

c : char ;

begin

writeln('Taper une touche') ;

readln(c) ;

case c of

'a'..'z','A'..'Z': if upcase(c) in ['A', 'E','I','O','U','Y']

then nature:='voyelle'

else nature:='consonne' ;

'0'..'9' : nature:= 'Chiffre' ;

else nature:='symbole' ;

end ;

writeln(nature) ;

end.


Exercice 7  : page 103

Écrire un programme qui permet d'afficher le nombre de jour d'un mois donné.

Corrigé :

Algorithme :

  1. Début mois

  1. Ecrire(''Donner le n° de mois''), lire(n)

  2. Selon n faire

1,3,5,7,8,10,12 : nb <-- 31

4,6,9,11 : nb <-- 30

2 : Ecrire(''Donner l'année ''), lire(a)

Si (a mod 400 =0) ou ( (a mod 4 =0) et (a mod 100 <>0) )

alors nb <-- 29

sinon nb <-- 28

Finsi

FinSelon

  1. Ecrire(''Le nombre de jour est '',nb)

  2. Fin mois


pascal :

Program mois ;

uses wincrt ;

var

n,a,nb : integer ;

begin


Write('Donner le n° de mois ') ; readln(n) ;

case n of

1,3,5,7,8,10,12 : nb:= 31;

4,6,9,11 : nb:= 30;

2 : begin

write('Donner l''année ');readln(a) ;

if (a mod 400 =0) OR ( (a mod 4 =0) AND (a mod 100 <>0) ) then nb:= 29

else nb:= 28 ;

End ;

End ;

writeln('Le nombre de jour est ',nb) ;


End.



NB:Une année bissextile est une année comptant 366 jours au lieu de 365, c'est-à-dire une année comprenant un 29 février (exemple 2012)

sont bissextiles les années:

  • divisibles par 4 mais non divisibles par 100

  • divisibles par 400.








Date d'ajout de la page: 10/11/2013   Dernière mise à jour de la page: 10/11/2013




Dernière modification: 12 juin 2018

K i t e b . n e t © 2008-2018